Page 34 of 47 FirstFirst ... 242932333435363944 ... LastLast
Results 661 to 680 of 926

Thread: Fate/Stay Night [Realta Nua] - Ultimate Edition - 2022

  1. #661
    Quote Originally Posted by NM64 View Post
    First off, just plain-old double-clicking on the "mpv.exe" file and then dragging-and-dropping an h.264 MP4 video file into the mpv program window resulting in the video playing back without issue on both the AMD and Intel PC(s).

    But when I tried to run mpv from the command line via your command line arguments, I got the following on both the AMD and Intel PC(s):

    Try the following command line arguments instead:
    mpv --gpu-context=win --vo=gpu --msg-level=all=debug /path/to/video.mp4
    (while replacing /path/to/video.mp4 with a path to a video file)

  2. #662
    屍鬼 Ghoul
    Join Date
    Jan 2022
    Location
    Singapore
    Gender
    Male
    Posts
    32
    I found a bug, this was on version 1.1.0 before the latest update. When I was using the x2.4 resolution the mobile window did not fit the 4:3 ratio, it works fine when in 16:9 and match desktop.
    Also, the status screen has black lines when using x2.4 resolution.

  3. #663
    Resident straight-male kuutsundere NM64's Avatar
    Join Date
    Jan 2013
    Location
    Northeast Ohio
    Age
    32
    Posts
    2,125
    Quote Originally Posted by Alyinghood View Post
    Try the following command line arguments instead:
    mpv --gpu-context=win --vo=gpu --msg-level=all=debug /path/to/video.mp4
    (while replacing /path/to/video.mp4 with a path to a video file)
    That worked, though the information overflowed the top of command line window (yes, I scrolled it to the top) even when I paused the video immediately after it started playing, so I had to make mpv output to an actual log file by instead running the following in the command line:

    Code:
    mpv --gpu-context=win --vo=gpu --msg-level=all=debug log-file=log.txt wpUjnZgtzXEI_psvita_op_hf.mp4
    Oh yeah and, for reference, I used the video wpUjnZgtzXEI_psvita_op_hf.mp4 file taken from my post at the top of page 53 in the old "Ultimate Edition" forum thread:




    Anyway, here are the logs on three different PCs; note that the HD5870 PC has a somewhat borky installation of Windows and, possibly due to that, the video file actually did not display on that specific PC even when I just double-clicked on mpv.exe and drag-and-dropped the video file so I'm not entire sure how valid the results are for that specific PC (please do not try to spend much time at all on that specific configuration since video playback via mpv.exe worked on the AMD E-350 system which, architecturally, isn't that far removed - think Nvidia 400 vs 500 series, yet it still "just worked" despite running a completely stock, non-updated copy of Win7 SP1 64bit):

    Intel 965GMA: https://ttm.sh/qAQ.txt

    AMD E-350 APU (integrated Radeon HD6310): https://ttm.sh/qAE.txt

    borky Radeon HD5870: https://ttm.sh/qAh.txt
    Last edited by NM64; September 3rd, 2022 at 08:12 PM.
    Beast Lair's resident straight-male kuutsundere
    (because just "tsundere" makes people think of "Shana clones" *shivers*)

    Fate/stay night-related extended music loops @ my YouTube channel

  4. #664
    Quote Originally Posted by NM64 View Post
    That worked, though the information overflowed the top of command line window (yes, I scrolled it to the top) even when I paused the video immediately after it started playing, so I had to make mpv output to an actual log file by instead running the following in the command line:

    Code:
    mpv --gpu-context=win --vo=gpu --msg-level=all=debug log-file=log.txt wpUjnZgtzXEI_psvita_op_hf.mp4
    Oh yeah and, for reference, I used the video wpUjnZgtzXEI_psvita_op_hf.mp4 file taken from my post at the top of page 53 in the old "Ultimate Edition" forum thread:




    Anyway, here are the logs on three different PCs; note that the HD5870 PC has a somewhat borky installation of Windows and, possibly due to that, the video file actually did not display on that specific PC even when I just double-clicked on mpv.exe and drag-and-dropped the video file so I'm not entire sure how valid the results are for that specific PC (please do not try to spend much time at all on that specific configuration since video playback via mpv.exe worked on the AMD E-350 system which, architecturally, isn't that far removed - think Nvidia 400 vs 500 series, yet it still "just worked" despite running a completely stock, non-updated copy of Win7 SP1 64bit):

    Intel 965GMA: https://ttm.sh/qAQ.txt

    AMD E-350 APU (integrated Radeon HD6310): https://ttm.sh/qAE.txt

    borky Radeon HD5870: https://ttm.sh/qAh.txt
    Okay, I may have figured out a few things.

    1. Intel 965GMA is using software rendering under a VMWare driver. In that case, it will explicitly fail.
    2. Radeon HD5870 has OpenGL errors

    Please try the following on all the machines:
    mpv --gpu-context=d3d11 --vo=gpu /path/to/video.mp4
    (while replacing /path/to/video.mp4 with a path to a video file)

    All I need to know is if the video plays back correctly or not.

  5. #665
    屍鬼 Ghoul
    Join Date
    Jan 2022
    Location
    Singapore
    Gender
    Male
    Posts
    32
    Quote Originally Posted by TrainerRad164 View Post
    I found a bug, this was on version 1.1.0 before the latest update. When I was using the x2.4 resolution the mobile window did not fit the 4:3 ratio, it works fine when in 16:9 and match desktop.
    Okay, so I updated the game to version 1.1.1. While the status screen doesn't have the black lines the mobile window still has the same problem in the previous update just that when I want to switch I have to restart the whole game.
    Last edited by TrainerRad164; September 4th, 2022 at 07:22 AM.

  6. #666
    Resident straight-male kuutsundere NM64's Avatar
    Join Date
    Jan 2013
    Location
    Northeast Ohio
    Age
    32
    Posts
    2,125
    Quote Originally Posted by Alyinghood View Post
    1. Intel 965GMA is using software rendering under a VMWare driver. In that case, it will explicitly fail.
    2. Radeon HD5870 has OpenGL errors
    What about the AMD E-350 (Radeon HD6310)? As mentioned, that plays the video without issue in mpv.exe yet, in ultimate edition, it exhibits the exact same issue as the borky HD5870. Did you perhaps misunderstand my statement about a borky Windows install and mistook the E-350 (HD6310) as the borky installation instead? They're on two completely different PCs.

    Regardless, should I still try the --gpu-context=d3d11 on the E-350 (HD6310) for completion sake?

    Also there's a funny thing about OpenGL compliance that, supposedly, AMD follows the spec to a T but so much OpenGL software is designed around Nvidia (including the use of various OpenGL extensions and stuff) to the point that AMD's OpenGL ends up looking "buggy"...supposedly.
    Beast Lair's resident straight-male kuutsundere
    (because just "tsundere" makes people think of "Shana clones" *shivers*)

    Fate/stay night-related extended music loops @ my YouTube channel

  7. #667
    Quote Originally Posted by NM64 View Post
    What about the AMD E-350 (Radeon HD6310)?
    I didn't notice anything.
    Quote Originally Posted by NM64 View Post
    Regardless, should I still try the --gpu-context=d3d11 on the E-350 (HD6310) for completion sake?
    Yes.

  8. #668
    Resident straight-male kuutsundere NM64's Avatar
    Join Date
    Jan 2013
    Location
    Northeast Ohio
    Age
    32
    Posts
    2,125
    Quote Originally Posted by Alyinghood View Post
    Please try the following on all the machines:
    mpv --gpu-context=d3d11 --vo=gpu /path/to/video.mp4
    (while replacing /path/to/video.mp4 with a path to a video file)

    All I need to know is if the video plays back correctly or not.
    AMD E-350 (HD6310) worked without issue

    Intel 965GMA failed: https://ttm.sh/q_P.txt

    Radeon HD5870 failed: https://ttm.sh/q_b.txt
    Beast Lair's resident straight-male kuutsundere
    (because just "tsundere" makes people think of "Shana clones" *shivers*)

    Fate/stay night-related extended music loops @ my YouTube channel

  9. #669
    Quote Originally Posted by NM64 View Post
    AMD E-350 (HD6310) worked without issue

    Intel 965GMA failed: https://ttm.sh/q_P.txt

    Radeon HD5870 failed: https://ttm.sh/q_b.txt
    For the ones that failed, could you ensure that "d3dcompiler_43.dll" is in the same directory as "mpv.exe", then try again?

  10. #670
    Resident straight-male kuutsundere NM64's Avatar
    Join Date
    Jan 2013
    Location
    Northeast Ohio
    Age
    32
    Posts
    2,125
    So um, what ever happened to that FireGL GPU you had around...?

    Quote Originally Posted by Alyinghood View Post
    For the ones that failed, could you ensure that "d3dcompiler_43.dll" is in the same directory as "mpv.exe", then try again?
    Technically I don't know 100% for sure if the DLL was there or not but, in the self-made ZIP archive that I put on a USB flash drive that I used for testing on all 3 PCs, the DLL is present.

    What I do know for sure however is that I even include a .sha1 checksum file of all of the contents of my self-made ZIP archive that I was OCD enough to always run before doing the previous mpv tests and, sure enough, the .sha1 checksum file not only lists "d3dcompiler_43.dll" but it even lists it as the very first file!
    Beast Lair's resident straight-male kuutsundere
    (because just "tsundere" makes people think of "Shana clones" *shivers*)

    Fate/stay night-related extended music loops @ my YouTube channel

  11. #671
    Thanks for your continuous work guys. Possible silly question, between x1.6 and x2.0 presets there are virtually no difference in image quality except resolution? Also how to make text font a bit smaller?
    Last edited by Yev; September 5th, 2022 at 01:29 AM.

  12. #672
    Quote Originally Posted by NM64 View Post
    So um, what ever happened to that FireGL GPU you had around...?
    I have the card on hand, but still need to prepare an environment for it.

    Quote Originally Posted by NM64 View Post
    Technically I don't know 100% for sure if the DLL was there or not but, in the self-made ZIP archive that I put on a USB flash drive that I used for testing on all 3 PCs, the DLL is present.

    What I do know for sure however is that I even include a .sha1 checksum file of all of the contents of my self-made ZIP archive that I was OCD enough to always run before doing the previous mpv tests and, sure enough, the .sha1 checksum file not only lists "d3dcompiler_43.dll" but it even lists it as the very first file!
    The reason I say that is because the log file says the DLL file is missing or cannot be loaded.

    Could you try installing Universal C Runtime https://support.microsoft.com/en-us/...9-49f5c49f4732 and then try again?


    Quote Originally Posted by Yev View Post
    Thanks for your continuous work guys. Possible silly question, between x1.6 and x2.0 presets there are virtually no difference in image quality except resolution?
    As by definition, there is difference in image quality.
    Quote Originally Posted by Yev View Post
    Also how to make text font a bit smaller?
    Select a lower resolution or window size.

  13. #673
    Resident straight-male kuutsundere NM64's Avatar
    Join Date
    Jan 2013
    Location
    Northeast Ohio
    Age
    32
    Posts
    2,125
    Quote Originally Posted by Alyinghood View Post
    Could you try installing Universal C Runtime https://support.microsoft.com/en-us/...9-49f5c49f4732 and then try again?
    I can but I question the benefit of that when the system that mpv.exe does work on, the AMD E-350, has a bone-stock copy of Win7 SP1 64bit with no updates (that SSD is basically used for nothing more than a music player over HDMI through our home theater system; for actual laptop use I swap the SSD for a different one).

    That being said, I did previously state that I don't think it's wise to put much stock into the HD5870 results since that PC has had various issues with other pieces of software as well and really should have had the OS re-installed ages ago (but the PC has been planned to have its hardware revamped for just as long, yet it keeps not happening...)


    EDIT: Really, the bigger concern is why mpv.exe "just worked" on the E-350 yet the blue program window OP issue in v1.1.x occurs on it as well... unless you think universal C runtime would help with the VN OP issue itself?
    Last edited by NM64; September 5th, 2022 at 02:23 PM.
    Beast Lair's resident straight-male kuutsundere
    (because just "tsundere" makes people think of "Shana clones" *shivers*)

    Fate/stay night-related extended music loops @ my YouTube channel

  14. #674
    Quote Originally Posted by NM64 View Post
    EDIT: Really, the bigger concern is why mpv.exe "just worked" on the E-350 yet the blue program window OP issue in v1.1.x occurs on it as well... unless you think universal C runtime would help with the VN OP issue itself?
    I'm attempting to work out whether it would be useful to set the default rendering backend to d3d11 instead of wgl.

  15. #675
    Resident straight-male kuutsundere NM64's Avatar
    Join Date
    Jan 2013
    Location
    Northeast Ohio
    Age
    32
    Posts
    2,125
    Quote Originally Posted by Alyinghood View Post
    I'm attempting to work out whether it would be useful to set the default rendering backend to d3d11 instead of wgl.
    I will admit that I am a bit concerned if that'll make WINE compatibility worse since, as it stands, the OPs "just work" even on that 15-year old Intel 965GMA when running through WINE and also "just work" on both AMD GPUs EDIT: err, on both AMD GPUs in WINE.

    In particular, for the Dolphin 5.0 CPU benchmark that I manage the forum thread for, my pre-packaged "for dummies" Windows version is set to Direct3D11 so that it can work on things like my Intel 965GMA, implying to me that Dolphin's D3D11 requirements are less than that of mpv. Thing is though, even on a Ryzen 4800U, Dolphin 5.0 set to Direct3D11 just crashes when running through WINE-staging 7.15; I have to have Dolphin 5.0 set to OpenGL in order to get it to run through WINE.

    Therefore, if mpv requires more D3D11 features than Dolphin, yet even Dolphin's D3D11 cannot be ran through WINE-staging 7.15 on a 1-gen-old integrated AMD GPU architecture (Ryzen 5000 uses the same GPU architecture, and RDNA1 was never used for integrated graphics), then switching ultimate edition's embedded mpv to d3d11 instead could result in bad things for LInux users even on modern hardware and software e.g. the Steam Deck or other, future SteamOS devices since these sort of "gaming tablets" seem pretty ideally suited for reading visual novels in a manner similar to ebook readers and such.

    (now obviously, if one were interested in actually using Dolphin for actual emulation on Linux rather than as a D3D11-through-WINE test, then you'd download and install the Dolphin flatpak or the like)


    So, I'll be honest, between having compatibility with older GPUs on Windows and having compatibility with newer GPUs on Linux, I'd take the latter.


    With all of that being said, I do have an AMD A8-7600 which, in terms of integrated graphics architecture generations, is pretty much right between the AMD E-350 and the Ryzen 4800U. I would actually be willing to quickly throw together a bone-stock installation of Win7 SP1 64bit onto that PC (assuming that one of my existing Win7 SP1 64bit SSDs won't "just work" as-is...though I had minimal luck last time I tried that despite being able to get Haswell Win7 SP1 64bit installations booted on the very same aforementioned AMD E-350 PC and vice-versa) just to see once and for all if a more modern AMD GPU also has issues playing the OPs in ultimate edition or not.

    (for reference, the device with a Ryzen 4800U only takes NVMe SSDs and, well, I only have one NVMe SSD and it's the one already in the 4800U device and it has Linux Mint 20.3 on it already and is what I'm typing from right now, so getting an installation of Windows natively running on that device would be difficult at this time).
    Last edited by NM64; September 5th, 2022 at 06:46 PM. Reason: clarifying that I mean the OPs work on both AMD GPUs in WINE
    Beast Lair's resident straight-male kuutsundere
    (because just "tsundere" makes people think of "Shana clones" *shivers*)

    Fate/stay night-related extended music loops @ my YouTube channel

  16. #676
    屍鬼 Ghoul
    Join Date
    Jan 2022
    Location
    Singapore
    Gender
    Male
    Posts
    32
    Quote Originally Posted by TrainerRad164 View Post
    Okay, so I updated the game to version 1.1.1. While the status screen doesn't have the black lines the mobile window still has the same problem in the previous update just that when I want to switch I have to restart the whole game.
    It would be nice if someone responded to this.

  17. #677
    Hey, poking my head in and curious about the state of the vita port of this project. Has there been an update to it as of yet?

  18. #678
    Quote Originally Posted by Rotted_Fish View Post
    Hey, poking my head in and curious about the state of the vita port of this project. Has there been an update to it as of yet?
    There are no new updates at this time.

  19. #679
    夜魔 Nightmare Bohemian Waxwing's Avatar
    Join Date
    Sep 2015
    Location
    Germany
    Age
    44
    Posts
    223
    Quote Originally Posted by TrainerRad164 View Post
    Okay, so I updated the game to version 1.1.1. While the status screen doesn't have the black lines the mobile window still has the same problem in the previous update just that when I want to switch I have to restart the whole game.
    Quote Originally Posted by TrainerRad164 View Post
    It would be nice if someone responded to this.
    We couldn't figure out what you meant. Please be more specific and detailed in your description.

  20. #680
    Resident straight-male kuutsundere NM64's Avatar
    Join Date
    Jan 2013
    Location
    Northeast Ohio
    Age
    32
    Posts
    2,125
    I have gone and done all of the OP and mpv tests on the AMD A8-7600 and have subsequently re-tested all of the OP and mpv tests on a much more fresh OS installation on the Intel 965GMA after discovering that its existing OS installation was actually a little bit borked.

    I also tested everything with the Universal C Runtime as well.


    These are my results; all PCs were running a stock or near-stock copy of Win7 Pro SP1 64bit with no updates (other than the borky OS installation) save for having GPU drivers installed (on the A8-7600 I had to disable driver signing enforcement because the latest drivers used SHA2 but non-updated Win7 SP1 lacks support for SHA2)


    EDIT: I made a minor boo-boo - the A8-7600 and non-borked 965GMA were tested on v1.1.0 before I installed Universal C Runtime... woops. Both were tested on both v1.1.0 and v1.1.1 after installing Universal C Runtime, and the E-350 was tested on both v1.1.0 and v1.1.1 before I installed Universal C Runtime and only v1.1.1 after installing Universal C Runtime.

    Also, with the default "mixed" movie setting, is it expected that the classic Fate OP plays after the prologue and the PS2 OP plays after the 3rd day? When does the Vita Fate OP play, if at all?


    EDIT 2: I just realized that the checksums in the first post have an unnecessary 0x in the beginning of each hash. This threw me for a loop since the v1.1.0 checksums did not have the leading 0x and both gtkhash, hashcheck shell extension, and 7zip do not put a 0x at the front of a hash. Needless to say, I think this could throw off a less-savvy user if it even threw me off.

    ...btw, does anybody have a checksum for the unstable patches? Maybe consider putting a .sfv file in the "unstable" folder specifically for those patches?


    AMD A8-7600 (integrated R7 graphics)
    WORKED - Ultimate Edition v1.1.0 withOUT Universal C Runtime
    WORKED - mpv.exe with its default configuration
    FAILED - mpv.exe set to use d3d11 withOUT Universal C Runtime
    WORKED - Universal C Runtime installation
    WORKED - mpv.exe set to use d3d11 with Universal C Runtime
    Not tested - Ultimate Edition v1.1.0 with Universal C Runtime
    WORKED - Ultimate Edition v1.1.1 with Universal C Runtime


    AMD E-350 (integrated HD6310 graphics)
    Blue program window with OP's music playing - Ultimate Edition v1.1.0 withOUT Universal C Runtime
    Blue program window with OP's music playing - Ultimate Edition v1.1.1 withOUT Universal C Runtime
    WORKED - mpv.exe with its default configuration
    WORKED - mpv.exe set to use d3d11 withOUT Universal C Runtime
    WORKED - Universal C Runtime installation
    WORKED - mpv.exe set to use d3d11 with Universal C Runtime
    Not tested - Ultimate Edition v1.1.0 with Universal C Runtime
    Blue program window with OP's music playing - Ultimate Edition v1.1.1 with Universal C Runtime


    Radeon HD5870 with borky OS installation
    Blue program window with OP's music playing - Ultimate Edition v1.1.0 withOUT Universal C Runtime
    Not tested - Ultimate Edition v1.1.1 withOUT Universal C Runtime
    White program window, possibly with the OP's music playing (I don't remember) - mpv.exe with its default configuration
    FAILED - mpv.exe set to use d3d11 withOUT Universal C Runtime
    FAILED - Universal C Runtime installation
    N/A - mpv.exe set to use d3d11 with Universal C Runtime
    N/A - Ultimate Edition v1.1.0 with Universal C Runtime
    N/A - Ultimate Edition v1.1.1 with Universal C Runtime


    Intel 965GMA with a proper non-borked OS installation
    "White program window of death" - Ultimate Edition v1.1.0 withOUT Universal C Runtime
    Not tested - Ultimate Edition v1.1.1 withOUT Universal C Runtime
    WORKED - mpv.exe with its default configuration
    [I forget the results] - mpv.exe set to use d3d11 withOUT Universal C Runtime
    WORKED - Universal C Runtime installation
    WORKED - mpv.exe set to use d3d11 with Universal C Runtime
    "White program window of death" - Ultimate Edition v1.1.0 with Universal C Runtime
    "White program window of death" - Ultimate Edition v1.1.1 with Universal C Runtime


    If you really want me to, I can test the HD5870 with a clean OS installation as well.

    I can similarly test an HD5450, HD4670, HD3200 pre-APU integrated graphics and even an ancient Radeon non-HD 7000 PCI non-express. I also have some older Nvidia GPUs like a 6600GT and 8400GS I could test with as well.

    I technically have an HD7850, HD6870 (not a typo), and a GTX260 (not a typo) but their larger size makes it considerably more difficult to physically install the card into the A8-7600's motherboard & case (which I use as a sort of test bench)...though the HD7850 is the shortest of the three and therefore might not be as difficult to physically install, so I might be able to at least test that one.
    Last edited by NM64; September 9th, 2022 at 03:53 PM.
    Beast Lair's resident straight-male kuutsundere
    (because just "tsundere" makes people think of "Shana clones" *shivers*)

    Fate/stay night-related extended music loops @ my YouTube channel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •